System Requirements

K2Store .5.x+ versions require the following:

PHP 5.3+

MySQL 5.0.41 or later

Joomla 2.5.8+

K2 2.x or later

cUrl

if some of the features of K2Store are not working, you should first check the availability of these requirements in your server. You can contact your hosting provider or check these by your self in the System Information menu in Joomla administrator.